用户
 找回密码
 入住 CI 中国社区
搜索
查看: 1253|回复: 6
收起左侧

[服务器] 服务器上加载不到models里的类,在本地正常

[复制链接]
发表于 2017-5-11 19:05:21 | 显示全部楼层 |阅读模式
咋回事..在本地正常..传到服务器上就出这个问题,,需要修改服务器哪里的配置
An uncaught Exception was encountered

Type: RuntimeException

Message: Unable to locate the model you have specified: News_model

Filename: /home/tan/web/file:///C:\Users\Administrator\AppData\Roaming\Tencent\TIM\Temp\%W@GJ$ACOF(TYDYECOKVDYB.pngtest.com/public_html/system/core/Loader.php

发表于 2017-5-12 11:16:16 | 显示全部楼层
大小写规范有没有遵守?
 楼主| 发表于 2017-5-12 14:20:28 | 显示全部楼层
Hex 发表于 2017-5-12 11:16
大小写规范有没有遵守?

有点搞不清楚了,application/core的类需要MY_C,C需要大写
application/controller下的文件名不能大写
 楼主| 发表于 2017-5-12 14:28:58 | 显示全部楼层
Hex 发表于 2017-5-12 11:16
大小写规范有没有遵守?

2.1.4版本和现在3.1.4版本冲突,大小写方面完全不一致.2.1.4正常了,3.1.4就出问题,反之亦然
发表于 2017-5-12 16:21:25 | 显示全部楼层
kao10324 发表于 2017-5-12 14:28
2.1.4版本和现在3.1.4版本冲突,大小写方面完全不一致.2.1.4正常了,3.1.4就出问题,反之亦然 ...

是的,2.x 和 3.x 是不兼容的,这个很正常,你具体用哪个版本就要遵守哪个版本的规定。
等到 CI4 的时候,就又不一样了,每个版本都有自己的规定。
 楼主| 发表于 2017-5-27 14:24:56 | 显示全部楼层
Hex 发表于 2017-5-12 16:21
是的,2.x 和 3.x 是不兼容的,这个很正常,你具体用哪个版本就要遵守哪个版本的规定。
等到 CI4 的时候 ...

那框架升级的话会很困难了
发表于 2017-5-27 15:11:31 | 显示全部楼层
kao10324 发表于 2017-5-27 14:24
那框架升级的话会很困难了

升级的话有升级指南,可以对照升级。不过,升级也要看项目实际情况,并不是说必须要升级。

本版积分规则