用户
 找回密码
 入住 CI 中国社区
搜索
查看: 1651|回复: 5
收起左侧

whatsns问答系统3.7最新源码3月21号更新

[复制链接]
发表于 2018-3-21 14:41:13 | 显示全部楼层 |阅读模式
下载地址:
https://www.ask2.cn/downloads/whatsns_ask2V3.7pro_20180321.zip

此次不需要在php.ini中设置short_open_tag为On了,已经对模板解析中将短标记切换为正常的php代码。
发表于 2018-4-18 10:38:54 | 显示全部楼层
请问php7.2 mcrypt这个扩展没有,怎么解决?
 楼主| 发表于 2018-5-12 07:53:50 | 显示全部楼层
鲤鱼 发表于 2018-4-18 10:38
请问php7.2 mcrypt这个扩展没有,怎么解决?

这个巨坑,CI底层框架需要这个mcypt,我查了下php7.2好像已经废弃了
:
mcrypt 扩展已经过时了大约10年,并且用起来很复杂。因此它被废弃并且被 OpenSSL 所取代。 从PHP 7.2起它将被从核心代码中移除并且移到PECL中。
 楼主| 发表于 2018-5-12 08:15:58 | 显示全部楼层
鲤鱼 发表于 2018-4-18 10:38
请问php7.2 mcrypt这个扩展没有,怎么解决?

有个办法,找到基类控制器:
system\core\Controller.php
然后将 $this->load->library ( 'encrypt' );
这个注释就行,目前没发现什么后遗症,用不到
发表于 2018-5-12 13:37:21 | 显示全部楼层
所以说,要用 PHP 7 还是得上 CI 4。。。。。
发表于 2018-7-9 18:17:33 | 显示全部楼层
huangxuan258 发表于 2018-5-12 08:15
有个办法,找到基类控制器:
system\core\Controller.php
然后将 $this->load->library ( 'encrypt' );

感谢,果断可以!~

本版积分规则