用户
 找回密码
 入住 CI 中国社区
搜索
查看: 198|回复: 4
收起左侧

[服务器] 求助,上传到服务器后报错!

[复制链接]
发表于 2018-10-9 16:24:09 | 显示全部楼层 |阅读模式
Parse error: syntax error, unexpected T_CONST in /home/emowuleibelmlo6wuuylqeai/wwwroot/system/core/CodeIgniter.php on line 58

这个文件根本没有任何改动,请问怎么解决
发表于 2018-10-11 01:22:42 | 显示全部楼层
zc309268032 发表于 2018-10-10 20:53
我在windows上用phpstudy搭建的环境,用php7.0.12都报错,,用了php7.1以上才行,,不是说这个ci4在php7. ...

参考这里 https://github.com/bcit-ci/CodeIgniter4#server-requirements 确实最低是 PHP 7.1,所有信息都以官方说明或文档为准。
回复 支持 1 反对 0

使用道具 举报

发表于 2018-10-10 11:18:17 | 显示全部楼层
你的 PHP 版本是多少?你的 CI 版本是多少?看起来是版本不匹配。
 楼主| 发表于 2018-10-10 14:41:49 | 显示全部楼层
Hex 发表于 2018-10-10 11:18
你的 PHP 版本是多少?你的 CI 版本是多少?看起来是版本不匹配。

多谢!确实是服务器php版本过低导致!
发表于 2018-10-10 20:53:23 | 显示全部楼层
Hex 发表于 2018-10-10 11:18
你的 PHP 版本是多少?你的 CI 版本是多少?看起来是版本不匹配。

我在windows上用phpstudy搭建的环境,用php7.0.12都报错,,用了php7.1以上才行,,不是说这个ci4在php7.0上都能跑,为啥现在要php7.1了

本版积分规则