用户
 找回密码
 入住 CI 中国社区
搜索
查看: 558|回复: 5
收起左侧

[数据库] 大家好,我的ci 从PHP5.3升级到 PHP5.5后,报错了

[复制链接]
发表于 2018-3-30 14:45:27 | 显示全部楼层 |阅读模式
大家好 ,我的 ci框架在 PHP5.3下正常,  但是升级到PHP5.5 后 ,不能正常运行了!

系统:  linux

操作: PHP5.3  升级 PHP5.5

服务器:  Apache

结果 :  报错    Access denied.


为何 会提示 数据库 拒绝访问呢  ?

请大牛回答
发表于 2018-3-31 01:02:45 | 显示全部楼层
发个报错截图看一下吧。
 楼主| 发表于 2018-3-31 14:07:06 | 显示全部楼层
Hex 发表于 2018-3-31 01:02
发个报错截图看一下吧。

你好 ,我只要 调用 url ,就报错 ,报错的内容是一样的!

QQ截图20180331140218.jpg


所有的 url ,都是这个错误 , 我是 从 PHP5.2 升级到 PHP5.5 后,就这样了!   使用ci3.0框架

大牛看看 ,这个 地址 试试  ? http://js1979.cn/shopapi/index.php/custom_order/create_order
发表于 2018-4-1 02:06:36 | 显示全部楼层
shulun743 发表于 2018-3-31 14:07
你好 ,我只要 调用 url ,就报错 ,报错的内容是一样的!

这个错误和 CI 无关,这是一个 nginx 或者 apache 配置问题。
 楼主| 发表于 2018-4-2 13:41:51 | 显示全部楼层
Hex 发表于 2018-4-1 02:06
这个错误和 CI 无关,这是一个 nginx 或者 apache 配置问题。

大牛你好,感谢回复, 我想咨询一下 ,这个 Apache 等服务器 应该怎么调试配置呢?

我之前是 PHP5.3 运行正常 , 结果升级PHP5.5后,  就报错了?

我应该怎么 调整呢 ?  麻烦大牛;了
发表于 2018-4-3 17:59:58 | 显示全部楼层
shulun743 发表于 2018-4-2 13:41
大牛你好,感谢回复, 我想咨询一下 ,这个 Apache 等服务器 应该怎么调试配置呢?

我之前是 PHP5.3 运 ...

这个得具体看你的服务器配置,需要上服务器调试。

本版积分规则