用户
 找回密码
 入住 CI 中国社区
搜索
查看: 536|回复: 9
收起左侧

[版本 3.x] 请问3x是否能够完全支持php7?

[复制链接]
发表于 2018-5-12 08:37:21 | 显示全部楼层 |阅读模式
刚才去github上看了下4x还在开发。。。3x不知道能不能很好的支持php7
有将ci3跑在php7的大神说下吗?可能会出现什么问题?
发表于 2018-5-12 08:42:13 | 显示全部楼层
还没发现有问题
 楼主| 发表于 2018-5-12 08:45:20 | 显示全部楼层
52lin 发表于 2018-5-12 08:42
还没发现有问题

谢谢,你现在用的是哪个ci版本和php版本?
发表于 2018-5-12 08:53:39 | 显示全部楼层
CI 3.0.4 + CentOS 7.4.1708 + PHP7.2.4
发表于 2018-5-12 08:54:46 | 显示全部楼层
flyqie 发表于 2018-5-12 08:45
谢谢,你现在用的是哪个ci版本和php版本?


CI 3.0.4 + CentOS 7.4.1708 + PHP7.2.4
 楼主| 发表于 2018-5-12 09:12:19 | 显示全部楼层
52lin 发表于 2018-5-12 08:54
CI 3.0.4 + CentOS 7.4.1708 + PHP7.2.4

谢谢
发表于 2018-5-12 17:12:42 | 显示全部楼层
没有问题的 直接上
 楼主| 发表于 2018-5-13 18:36:12 | 显示全部楼层
连普科技 发表于 2018-5-12 17:12
没有问题的 直接上

谢谢
发表于 2018-5-15 11:47:52 | 显示全部楼层
本帖最后由 euii 于 2018-5-15 11:50 编辑

mcrypt_module 这个类不支持了吧。我看CI里 password_hash()使用了这个方法 mcrypt_create_iv
发表于 2018-5-15 14:17:37 | 显示全部楼层
对  mcrypt 7.1以后就没有这个 扩展了

本版积分规则